# GHSA-xphf-cx8h-7q9g: `openssl` `X509StoreRef::objects` is unsound

> Unsound reference handling in Rust OpenSSL bindings allows race conditions, potentially leading to memory corruption or crashes.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2023
- **Also known as:** RUSTSEC-2023-0072

## What is GHSA-xphf-cx8h-7q9g?

GHSA-xphf-cx8h-7q9g is a vulnerability in openssl, published on 23 Nov 2023. 

### Official description

This function returned a shared reference into an OpenSSL datastructure but did not account for interior mutability. OpenSSL may modify the data behind this reference, meaning accesses can race and the reference is unsound.

Use of this function should be replaced with `X509StoreRef::all_certificates`.

## Which versions are affected by GHSA-xphf-cx8h-7q9g?

3 open source packages ship an affected version, including openssl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | From 0.0.0-0 | 0.10.60 |
| `openssl` | crates.io | From 0.10.29 | 0.10.60 |
| `openssl` | crates.io | From 0.10.29 | 0.10.60 |

## How do I fix GHSA-xphf-cx8h-7q9g?

Upgrade openssl to 0.10.60 or later.

## Is GHSA-xphf-cx8h-7q9g being exploited?

There is no known exploitation of GHSA-xphf-cx8h-7q9g in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-xphf-cx8h-7q9g and fix it if it is affected.

What it is: GHSA-xphf-cx8h-7q9g is a vulnerability in openssl, published on 23 Nov 2023. 
Exploitation: There is no known exploitation of GHSA-xphf-cx8h-7q9g in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected from 0.0.0-0; fixed in 0.10.60
- openssl (crates.io): affected from 0.10.29; fixed in 0.10.60
- openssl (crates.io): affected from 0.10.29; fixed in 0.10.60

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-xphf-cx8h-7q9g/ (Markdown: https://insights.sbomify.com/GHSA-xphf-cx8h-7q9g/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-xphf-cx8h-7q9g

---
From sbomify Insights: https://insights.sbomify.com/GHSA-xphf-cx8h-7q9g/
Summaries are generated and may contain mistakes; the official description above is the record.
