{"answers":{"affected":"2 open source packages ship an affected version, including io.netty:netty-codec-http2.","exploited":"There is no known exploitation of GHSA-xpw8-rcwv-8f8p in the wild and no public exploit code.","fix":"Upgrade io.netty:netty-codec-http2 to 4.1.100.Final or later.","what":"GHSA-xpw8-rcwv-8f8p is a denial of service vulnerability in io.netty:netty-codec-http2, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xpw8-rcwv-8f8p and fix it if it is affected.\n\nWhat it is: GHSA-xpw8-rcwv-8f8p is a denial of service vulnerability in io.netty:netty-codec-http2, published on 10 Oct 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xpw8-rcwv-8f8p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.100.Final\n- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.100.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xpw8-rcwv-8f8p/ (Markdown: https://insights.sbomify.com/GHSA-xpw8-rcwv-8f8p/index.md)","id":"GHSA-xpw8-rcwv-8f8p","markdown":"https://insights.sbomify.com/GHSA-xpw8-rcwv-8f8p/index.md","name":"GHSA-xpw8-rcwv-8f8p","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java HTTP/2 library","requires_auth":"none","summary":"Attackers can cause denial of service on HTTP/2 servers by sending frequent RST frames, requiring library upgrades to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"A client might overload the server by issue frequent RST frames. This can cause a massive amount of load on the remote system and so cause a DDOS attack. \n\n### Impact\nThis is a DDOS attack, any http2 server is affected and so you should update as soon as possible.\n\n### Patches\nThis is patched in version 4.1.100.Final.\n\n### Workarounds\nA user can limit the amount of RST frames that are accepted per connection over a timeframe manually using either an own `Http2FrameListener` implementation or an `ChannelInboundHandler` implementation (depending which http2 API is used).\n\n### References\n- https://www.cve.org/CVERecord?id=CVE-2023-44487\n- https://blog.cloudflare.com/technical-breakdown-http2-rapid-reset-ddos-attack/\n- https://cloud.google.com/blog/products/identity-security/google-cloud-mitigated-largest-ddos-attack-peaking-above-398-million-rps/","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"io.netty:netty-codec-http2 vulnerable to HTTP/2 Rapid Reset Attack","id":"GHSA-xpw8-rcwv-8f8p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["4.1.100.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty:netty-codec-http2","purl":null,"source":"GHSA-xpw8-rcwv-8f8p"},{"ecosystem":"Maven","fixed":["4.1.100.Final"],"introduced":["0"],"last_affected":[],"package":"io.netty:netty-codec-http2","purl":"pkg:maven/io.netty/netty-codec-http2","source":"GHSA-xpw8-rcwv-8f8p"}],"products":null,"published":"2023-10-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service on HTTP/2 servers by sending frequent RST frames, requiring library upgrades to mitigate.","url":"https://insights.sbomify.com/GHSA-xpw8-rcwv-8f8p/"}