{"answers":{"affected":"2 open source packages ship an affected version, including deap.","exploited":"There is no known exploitation of GHSA-xrmp-99wj-p6jc in the wild and no public exploit code.","fix":"Upgrade deap to 1.0.1 or later.","what":"GHSA-xrmp-99wj-p6jc is a vulnerability in deap, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xrmp-99wj-p6jc and fix it if it is affected.\n\nWhat it is: GHSA-xrmp-99wj-p6jc is a vulnerability in deap, published on 31 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xrmp-99wj-p6jc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deap (npm): affected all versions; fixed in 1.0.1\n- deap (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xrmp-99wj-p6jc/ (Markdown: https://insights.sbomify.com/GHSA-xrmp-99wj-p6jc/index.md)","id":"GHSA-xrmp-99wj-p6jc","markdown":"https://insights.sbomify.com/GHSA-xrmp-99wj-p6jc/index.md","name":"GHSA-xrmp-99wj-p6jc","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript utility library","requires_auth":"none","summary":"Prototype pollution in the deap library allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `deap` before 1.0.1 are vulnerable to prototype pollution.\n\n## Recommendation\n\nUpdate to version 1.0.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Prototype Pollution in deap","id":"GHSA-xrmp-99wj-p6jc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"deap","purl":null,"source":"GHSA-xrmp-99wj-p6jc"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"deap","purl":"pkg:npm/deap","source":"GHSA-xrmp-99wj-p6jc"}],"products":null,"published":"2019-05-31","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Prototype pollution in the deap library allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.","url":"https://insights.sbomify.com/GHSA-xrmp-99wj-p6jc/"}