# GHSA-xv3q-jrmm-4fxv: Authentication Bypass in @strapi/plugin-users-permissions

> Attackers can bypass authentication and impersonate users by forging JWTs when using the AWS Cognito provider in Strapi.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2023

## What is GHSA-xv3q-jrmm-4fxv?

GHSA-xv3q-jrmm-4fxv is an authentication bypass vulnerability in @strapi/plugin-users-permissions, published on 18 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Summary

Strapi through 4.5.6 does not verify the access or ID tokens issued during the OAuth flow when the AWS Cognito login provider is used for authentication.

### Details

Strapi through 4.5.6 does not verify the access or ID tokens issued during the OAuth flow when the AWS Cognito login provider is used for authentication. A remote attacker could forge an ID token that is signed using the 'None' type algorithm to bypass authentication and impersonate any user that use AWS Cognito for authentication.

### IoC

Reviewing of application logs is recommended to detect any suspicious activity. Running the following regex pattern will extract all ID tokens sent to `/api/auth/cognito/callback`.

`/\/api\/auth\/cognito\/callback\?[\s\S]*id_token=\s*([\S]*)/`

Once you have a list of the ID tokens, you will need to verify each token using the public key file for your AWS Cognito user pool that you can download from `https://cognito-idp.{region}.amazonaws.com/{userPoolId}/.well-known/jwks.json`. If there are any JWT tokens that cannot be verified using the correct public key, then you need to inspect the JWT body and see if it contains the `email` and `cognito:username` claims (example below).

```json
{
  "cognito:username": "auth-bypass-example",
  "email": "user@example.com"
}
```

If there are any JWTs that have this body, verify when the account with the email address was created. If the account was created earlier than the request to `/api/auth/cognito/callback` with the invalid JWT token, then you need to contact the user to inform them their account has been breached!

After upgrading to Strapi v4.6.0 or greater you will need to reconfigure your AWS Cognito provider to include the JWKS URL for it to work properly. If you do not reconfigure your provider you will receive an error message when attempting to login.

### Impact

Any Strapi user using the users-permissions AWS Cognito provider before 4.6.0

## Which versions are affected by GHSA-xv3q-jrmm-4fxv?

2 open source packages ship an affected version, including @strapi/plugin-users-permissions.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-users-permissions` | npm | From 3.2.1 | 4.6.0 |
| `@strapi/plugin-users-permissions` | npm | From 3.2.1 | 4.6.0 |

## How do I fix GHSA-xv3q-jrmm-4fxv?

Upgrade @strapi/plugin-users-permissions to 4.6.0 or later.

## Is GHSA-xv3q-jrmm-4fxv being exploited?

There is no known exploitation of GHSA-xv3q-jrmm-4fxv in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-xv3q-jrmm-4fxv and fix it if it is affected.

What it is: GHSA-xv3q-jrmm-4fxv is an authentication bypass vulnerability in @strapi/plugin-users-permissions, published on 18 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-xv3q-jrmm-4fxv in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/plugin-users-permissions (npm): affected from 3.2.1; fixed in 4.6.0
- @strapi/plugin-users-permissions (npm): affected from 3.2.1; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-xv3q-jrmm-4fxv/ (Markdown: https://insights.sbomify.com/GHSA-xv3q-jrmm-4fxv/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-xv3q-jrmm-4fxv

---
From sbomify Insights: https://insights.sbomify.com/GHSA-xv3q-jrmm-4fxv/
Summaries are generated and may contain mistakes; the official description above is the record.
