GHSA-xv8g-fj9h-6gmv Linkdave Missing Authentication on REST and WebSocket endpoints

Not scored Published

Unauthenticated attackers can control audio playback and access server statistics via exposed REST and WebSocket endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-xv8g-fj9h-6gmv?

GHSA-xv8g-fj9h-6gmv is a missing authorization vulnerability in github.com/shi-gg/linkdave, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The linkdave server does not enforce authentication on its REST and WebSocket routes in versions prior to 0.1.5.

Impact

An attacker with network access to the server port can:

  • Connect to the WebSocket endpoint (/ws) and receive a valid session_id in the OpReady response.
  • Use that session to invoke all REST player controls on any guild corresponding to their session id[1].
  • Enumerate server statistics and runtime information via the unauthenticated /stats endpoint (still public after the fix).

[1] If on >=0.1.0, attackers are restricted to creating, controlling and deleting players created within their own session ID.

Vulnerable Routes

The following routes were entirely unauthenticated in >= 0.0.1, < 0.1.5:

MethodPathDescription
POST/sessions/{session_id}/players/{guild_id}/playStart audio playback
POST/sessions/{session_id}/players/{guild_id}/pausePause playback
POST/sessions/{session_id}/players/{guild_id}/resumeResume playback
POST/sessions/{session_id}/players/{guild_id}/stopStop playback
POST/sessions/{session_id}/players/{guild_id}/seekSeek to position
PATCH/sessions/{session_id}/players/{guild_id}/volumeSet volume
DELETE/sessions/{session_id}/players/{guild_id}Disconnect from voice channel
GET/wsWebSocket event stream

Patches

Update to 0.1.5.

- image: ghcr.io/shi-gg/linkdave:0.1.4
+ image: ghcr.io/shi-gg/linkdave:latest

or

docker pull ghcr.io/shi-gg/linkdave:latest

After upgrading, set the LINKDAVE_PASSWORD environment variable to a strong secret value. If this variable is left unset, the server will still accept all connections without authentication even on >= 0.1.5.

Server configuration (e.g. compose.yml):

environment:
    LINKDAVE_PASSWORD: ${LINKDAVE_PASSWORD}
echo "LINKDAVE_PASSWORD=$(openssl rand -hex 16)" >> .env

To restart the stack, run

docker compose up -d

TypeScript client (0.1.5+):

The client automatically handles authentication. Pass the password when constructing the client:

const linkdave = new LinkDaveClient({
    nodes: [
        {
            name: "main",
            url: process.env.LINKDAVE_URI,
            password: process.env.LINKDAVE_PASSWORD
        }
    ]
});

Workarounds

If upgrading is not immediately possible, restrict network access to the server's port using a firewall so it is only accessible from trusted internal IP addresses.

Which versions are affected by GHSA-xv8g-fj9h-6gmv?

3 open source packages ship an affected version, including github.com/shi-gg/linkdave.

PackageAffectedFixed in
github.com/shi-gg/linkdave GoAll versions0.1.5
github.com/shi-gg/linkdave GoAll versions0.1.5
github.com/shi-gg/linkdave GoAll versions0.1.5

How do I fix GHSA-xv8g-fj9h-6gmv?

Upgrade github.com/shi-gg/linkdave to 0.1.5 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is GHSA-xv8g-fj9h-6gmv being exploited?

There is no known exploitation of GHSA-xv8g-fj9h-6gmv in the wild and no public exploit code.

Sources

Also known as GO-2026-4661.

Is GHSA-xv8g-fj9h-6gmv in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free