{"answers":{"affected":"2 open source packages ship an affected version, including @asymmetric-effort/specifyjs.","exploited":"There is no known exploitation of GHSA-xw57-23p8-9wc5 in the wild and no public exploit code.","fix":"Upgrade @asymmetric-effort/specifyjs to 0.2.136 or later.","what":"GHSA-xw57-23p8-9wc5 is a vulnerability in @asymmetric-effort/specifyjs, published on 2 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xw57-23p8-9wc5 and fix it if it is affected.\n\nWhat it is: GHSA-xw57-23p8-9wc5 is a vulnerability in @asymmetric-effort/specifyjs, published on 2 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xw57-23p8-9wc5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xw57-23p8-9wc5/ (Markdown: https://insights.sbomify.com/GHSA-xw57-23p8-9wc5/index.md)","id":"GHSA-xw57-23p8-9wc5","markdown":"https://insights.sbomify.com/GHSA-xw57-23p8-9wc5/index.md","name":"GHSA-xw57-23p8-9wc5","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm security library","requires_auth":"none","summary":"An incomplete localhost check allows bypassing security restrictions via IPv6 or other loopback addresses, requiring an upgrade to the library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Finding\n\n**Location**: `core/src/shared/secure-fetch.ts:52-54`\n\nThe localhost exception allowed `localhost` and `127.0.0.1` but did not cover `0.0.0.0`, `[::1]` (IPv6 localhost), or the full `127.0.0.0/8` loopback range.\n\n## Status\n\n**Fixed in v0.2.136** — Localhost detection now covers `localhost`, `127.0.0.1`, `[::1]`, `0.0.0.0`, and the full `127.x.x.x` range.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"@asymmetric-effort/specifyjs: Localhost bypass incomplete (IPv6, 0.0.0.0, 127.x range)","id":"GHSA-xw57-23p8-9wc5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":null,"source":"GHSA-xw57-23p8-9wc5"},{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":"pkg:npm/%40asymmetric-effort/specifyjs","source":"GHSA-xw57-23p8-9wc5"}],"products":null,"published":"2026-07-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An incomplete localhost check allows bypassing security restrictions via IPv6 or other loopback addresses, requiring an upgrade to the library.","url":"https://insights.sbomify.com/GHSA-xw57-23p8-9wc5/"}