{"answers":{"affected":"2 open source packages ship an affected version, including serve.","exploited":"There is no known exploitation of GHSA-xw79-hhv6-578c in the wild and no public exploit code.","fix":"Upgrade serve to 10.0.2 or later.","what":"GHSA-xw79-hhv6-578c is a cross-site scripting vulnerability in serve, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-xw79-hhv6-578c and fix it if it is affected.\n\nWhat it is: GHSA-xw79-hhv6-578c is a cross-site scripting vulnerability in serve, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-xw79-hhv6-578c in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serve (npm): affected all versions; fixed in 10.0.2\n- serve (npm): affected all versions; fixed in 10.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xw79-hhv6-578c/ (Markdown: https://insights.sbomify.com/GHSA-xw79-hhv6-578c/index.md)","id":"GHSA-xw79-hhv6-578c","markdown":"https://insights.sbomify.com/GHSA-xw79-hhv6-578c/index.md","name":"GHSA-xw79-hhv6-578c","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static server","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unencoded user input in the serve static file server.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `serve` prior to 10.0.2 are vulnerable to Cross-Site Scripting (XSS). The package does not encode output, allowing attackers to execute arbitrary JavaScript in the victim's browser if user-supplied input is rendered.\n\n## Recommendation\n\nUpgrade to version 10.0.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in serve","id":"GHSA-xw79-hhv6-578c","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"serve","purl":null,"source":"GHSA-xw79-hhv6-578c"},{"ecosystem":"npm","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"serve","purl":"pkg:npm/serve","source":"GHSA-xw79-hhv6-578c"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via unencoded user input in the serve static file server.","url":"https://insights.sbomify.com/GHSA-xw79-hhv6-578c/"}