GHSA-xwhj-pqcg-8rcr CakePHP vulnerable to Cross-site Scripting in some development error pages

Not scored Published

Attackers can execute scripts via XSS in CakePHP development error pages, requiring developers to upgrade or disable debug mode.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is GHSA-xwhj-pqcg-8rcr?

GHSA-xwhj-pqcg-8rcr is a cross-site scripting vulnerability in cakephp/cakephp, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only missing route and duplicate named route error pages.

Which versions are affected by GHSA-xwhj-pqcg-8rcr?

6 open source packages ship an affected version, including cakephp/cakephp.

PackageAffectedFixed in
cakephp/cakephp PackagistFrom 3.4.03.4.14
cakephp/cakephp PackagistFrom 3.4.03.4.14
cakephp/cakephp PackagistFrom 3.5.03.5.17
cakephp/cakephp PackagistFrom 3.5.03.5.17
cakephp/cakephp PackagistFrom 3.6.03.6.4
cakephp/cakephp PackagistFrom 3.6.03.6.4

How do I fix GHSA-xwhj-pqcg-8rcr?

Upgrade cakephp/cakephp to a fixed version for your release line: 3.4.14, 3.5.17 or 3.6.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is GHSA-xwhj-pqcg-8rcr being exploited?

There is no known exploitation of GHSA-xwhj-pqcg-8rcr in the wild and no public exploit code.

Sources

Is GHSA-xwhj-pqcg-8rcr in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free