{"answers":{"affected":"6 open source packages ship an affected version, including cakephp/cakephp.","exploited":"There is no known exploitation of GHSA-xwhj-pqcg-8rcr in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 3.4.14, 3.5.17 or 3.6.4.","what":"GHSA-xwhj-pqcg-8rcr is a cross-site scripting vulnerability in cakephp/cakephp, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-xwhj-pqcg-8rcr and fix it if it is affected.\n\nWhat it is: GHSA-xwhj-pqcg-8rcr is a cross-site scripting vulnerability in cakephp/cakephp, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-xwhj-pqcg-8rcr in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 3.4.0; fixed in 3.4.14\n- cakephp/cakephp (Packagist): affected from 3.4.0; fixed in 3.4.14\n- cakephp/cakephp (Packagist): affected from 3.5.0; fixed in 3.5.17\n- cakephp/cakephp (Packagist): affected from 3.5.0; fixed in 3.5.17\n- cakephp/cakephp (Packagist): affected from 3.6.0; fixed in 3.6.4\n- cakephp/cakephp (Packagist): affected from 3.6.0; fixed in 3.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xwhj-pqcg-8rcr/ (Markdown: https://insights.sbomify.com/GHSA-xwhj-pqcg-8rcr/index.md)","id":"GHSA-xwhj-pqcg-8rcr","markdown":"https://insights.sbomify.com/GHSA-xwhj-pqcg-8rcr/index.md","name":"GHSA-xwhj-pqcg-8rcr","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"CakePHP framework","requires_auth":"none","summary":"Attackers can execute scripts via XSS in CakePHP development error pages, requiring developers to upgrade or disable debug mode.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only `missing route` and `duplicate named route` error pages.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"CakePHP vulnerable to Cross-site Scripting in some development error pages","id":"GHSA-xwhj-pqcg-8rcr","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.4.14"],"introduced":["3.4.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-xwhj-pqcg-8rcr"},{"ecosystem":"Packagist","fixed":["3.4.14"],"introduced":["3.4.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-xwhj-pqcg-8rcr"},{"ecosystem":"Packagist","fixed":["3.5.17"],"introduced":["3.5.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-xwhj-pqcg-8rcr"},{"ecosystem":"Packagist","fixed":["3.5.17"],"introduced":["3.5.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-xwhj-pqcg-8rcr"},{"ecosystem":"Packagist","fixed":["3.6.4"],"introduced":["3.6.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-xwhj-pqcg-8rcr"},{"ecosystem":"Packagist","fixed":["3.6.4"],"introduced":["3.6.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-xwhj-pqcg-8rcr"}],"products":null,"published":"2023-01-20","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute scripts via XSS in CakePHP development error pages, requiring developers to upgrade or disable debug mode.","url":"https://insights.sbomify.com/GHSA-xwhj-pqcg-8rcr/"}