{"answers":{"affected":"2 open source packages ship an affected version, including buefy.","exploited":"There is no known exploitation of GHSA-xwqw-rf2q-xmhf in the wild and no public exploit code.","fix":"Upgrade buefy to 0.7.2 or later.","what":"GHSA-xwqw-rf2q-xmhf is a cross-site scripting vulnerability in buefy, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-xwqw-rf2q-xmhf and fix it if it is affected.\n\nWhat it is: GHSA-xwqw-rf2q-xmhf is a cross-site scripting vulnerability in buefy, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-xwqw-rf2q-xmhf in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- buefy (npm): affected all versions; fixed in 0.7.2\n- buefy (npm): affected all versions; fixed in 0.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xwqw-rf2q-xmhf/ (Markdown: https://insights.sbomify.com/GHSA-xwqw-rf2q-xmhf/index.md)","id":"GHSA-xwqw-rf2q-xmhf","markdown":"https://insights.sbomify.com/GHSA-xwqw-rf2q-xmhf/index.md","name":"GHSA-xwqw-rf2q-xmhf","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue.js UI library","requires_auth":"none","summary":"Attackers can execute remote code via DOM manipulation in the autocomplete list due to unencoded user input.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of buefy prior to 0.7.2 are vulnerable to Cross-Site Scripting, allowing attackers to manipulate the DOM and execute remote code. The autocomplete list renders user input as HTML without encoding.\n\n## Recommendation\n\nUpgrade to version 0.7.2 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in buefy","id":"GHSA-xwqw-rf2q-xmhf","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"buefy","purl":null,"source":"GHSA-xwqw-rf2q-xmhf"},{"ecosystem":"npm","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"buefy","purl":"pkg:npm/buefy","source":"GHSA-xwqw-rf2q-xmhf"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute remote code via DOM manipulation in the autocomplete list due to unencoded user input.","url":"https://insights.sbomify.com/GHSA-xwqw-rf2q-xmhf/"}