{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri.","exploited":"There is no known exploitation of GHSA-xxx9-3xcr-gjj3 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.13.4 or later.","what":"GHSA-xxx9-3xcr-gjj3 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-xxx9-3xcr-gjj3 and fix it if it is affected.\n\nWhat it is: GHSA-xxx9-3xcr-gjj3 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-xxx9-3xcr-gjj3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/ (Markdown: https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/index.md)","id":"GHSA-xxx9-3xcr-gjj3","markdown":"https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/index.md","name":"GHSA-xxx9-3xcr-gjj3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML library","requires_auth":"none","summary":"An XML injection flaw in the vendored Xerces parser allows attackers to cause a denial of service via infinite loops in JRuby Nokogiri.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nNokogiri v1.13.4 updates the vendored `xerces:xercesImpl` from 2.12.0 to 2.12.2, which addresses [CVE-2022-23437](https://nvd.nist.gov/vuln/detail/CVE-2022-23437). That CVE is scored as CVSS 6.5 \"Medium\" on the NVD record.\n\nPlease note that this advisory only applies to the **JRuby** implementation of Nokogiri `\u003c 1.13.4`.\n\n## Mitigation\n\nUpgrade to Nokogiri `\u003e= v1.13.4`.\n\n## Impact\n\n### [CVE-2022-23437](https://nvd.nist.gov/vuln/detail/CVE-2022-23437) in xerces-J\n\n- **Severity**: Medium\n- **Type**: [CWE-91](https://cwe.mitre.org/data/definitions/91.html) XML Injection (aka Blind XPath Injection)\n- **Description**: There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.\n- **See also**: https://github.com/advisories/GHSA-h65f-jvqw-m9fj","ecosystems":["RubyGems"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"XML Injection in Xerces Java affects Nokogiri","id":"GHSA-xxx9-3xcr-gjj3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-xxx9-3xcr-gjj3"},{"ecosystem":"RubyGems","fixed":["1.13.4"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-xxx9-3xcr-gjj3"}],"products":null,"published":"2022-04-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XML injection flaw in the vendored Xerces parser allows attackers to cause a denial of service via infinite loops in JRuby Nokogiri.","url":"https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/"}