# GHSA-xxx9-3xcr-gjj3: XML Injection in Xerces Java affects Nokogiri

> An XML injection flaw in the vendored Xerces parser allows attackers to cause a denial of service via infinite loops in JRuby Nokogiri.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022

## What is GHSA-xxx9-3xcr-gjj3?

GHSA-xxx9-3xcr-gjj3 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Summary

Nokogiri v1.13.4 updates the vendored `xerces:xercesImpl` from 2.12.0 to 2.12.2, which addresses [CVE-2022-23437](https://nvd.nist.gov/vuln/detail/CVE-2022-23437). That CVE is scored as CVSS 6.5 "Medium" on the NVD record.

Please note that this advisory only applies to the **JRuby** implementation of Nokogiri `< 1.13.4`.

## Mitigation

Upgrade to Nokogiri `>= v1.13.4`.

## Impact

### [CVE-2022-23437](https://nvd.nist.gov/vuln/detail/CVE-2022-23437) in xerces-J

- **Severity**: Medium
- **Type**: [CWE-91](https://cwe.mitre.org/data/definitions/91.html) XML Injection (aka Blind XPath Injection)
- **Description**: There's a vulnerability within the Apache Xerces Java (XercesJ) XML parser when handling specially crafted XML document payloads. This causes, the XercesJ XML parser to wait in an infinite loop, which may sometimes consume system resources for prolonged duration. This vulnerability is present within XercesJ version 2.12.1 and the previous versions.
- **See also**: https://github.com/advisories/GHSA-h65f-jvqw-m9fj

## Which versions are affected by GHSA-xxx9-3xcr-gjj3?

2 open source packages ship an affected version, including nokogiri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.4 |
| `nokogiri` | RubyGems | All versions | 1.13.4 |

## How do I fix GHSA-xxx9-3xcr-gjj3?

Upgrade nokogiri to 1.13.4 or later.

## Is GHSA-xxx9-3xcr-gjj3 being exploited?

There is no known exploitation of GHSA-xxx9-3xcr-gjj3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-xxx9-3xcr-gjj3 and fix it if it is affected.

What it is: GHSA-xxx9-3xcr-gjj3 is a denial of service vulnerability in nokogiri, published on 11 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-xxx9-3xcr-gjj3 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4
- nokogiri (RubyGems): affected all versions; fixed in 1.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/ (Markdown: https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-xxx9-3xcr-gjj3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-xxx9-3xcr-gjj3/
Summaries are generated and may contain mistakes; the official description above is the record.
