{"answers":{"affected":"1 open source package ship an affected version, including x509-validation.","exploited":"There is no known exploitation of HSEC-2023-0006 in the wild and no public exploit code.","fix":"Upgrade x509-validation to 1.4.8 or later.","what":"HSEC-2023-0006 is a vulnerability in x509-validation, published on 14 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for HSEC-2023-0006 and fix it if it is affected.\n\nWhat it is: HSEC-2023-0006 is a vulnerability in x509-validation, published on 14 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of HSEC-2023-0006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- x509-validation (Hackage): affected from 1.4.0; fixed in 1.4.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/HSEC-2023-0006/ (Markdown: https://insights.sbomify.com/HSEC-2023-0006/index.md)","id":"HSEC-2023-0006","markdown":"https://insights.sbomify.com/HSEC-2023-0006/index.md","name":"HSEC-2023-0006","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Haskell x509 library","requires_auth":"none","summary":"The x509-validation library fails to enforce path length constraints, allowing unauthorized intermediate CAs to issue certificates that are incorrectly accepted.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"# x509-validation does not enforce pathLenConstraint\n\n*x509-validation* prior to version 1.4.8 did not enforce the\npathLenConstraint value.  Constrained CAs could accidentally (or\ndeliberately) issue CAs below the maximum depth and\n*x509-validation* would accept certificates issued by the\nunauthorised intermediate CAs.","ecosystems":["Hackage"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"x509-validation does not enforce pathLenConstraint","id":"HSEC-2023-0006","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"Hackage","fixed":["1.4.8"],"introduced":["1.4.0"],"last_affected":[],"package":"x509-validation","purl":"pkg:hackage/x509-validation","source":"HSEC-2023-0006"}],"products":null,"published":"2025-11-14","related":[],"sources":[{"class":"open","licence":"CC0 1.0","name":"Haskell Security Response Team","prefix":"HSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"The x509-validation library fails to enforce path length constraints, allowing unauthorized intermediate CAs to issue certificates that are incorrectly accepted.","url":"https://insights.sbomify.com/HSEC-2023-0006/"}