{"answers":{"affected":"1 open source package ship an affected version, including ultralytics.","exploited":"There is no known exploitation of PYSEC-2024-154 in the wild and no public exploit code.","fix":"Upgrade ultralytics to 8.3.47 or later.","what":"PYSEC-2024-154 is a vulnerability in ultralytics, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for PYSEC-2024-154 and fix it if it is affected.\n\nWhat it is: PYSEC-2024-154 is a vulnerability in ultralytics, published on 10 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of PYSEC-2024-154 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ultralytics (PyPI): affected from 8.3.41; fixed in 8.3.47\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/PYSEC-2024-154/ (Markdown: https://insights.sbomify.com/PYSEC-2024-154/index.md)","id":"PYSEC-2024-154","markdown":"https://insights.sbomify.com/PYSEC-2024-154/index.md","name":"PYSEC-2024-154","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python machine learning library","requires_auth":"none","summary":"Attackers can execute arbitrary code via malicious cryptocurrency miner software injected into compromised ultralytics package releases.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Ultralytics has identified a supply chain attack\naffecting affecting multiple versions of the ultralytics package.\nThe compromised versions contained unauthorized code that\ndownloaded and executed cryptocurrency mining software\nwhen instantiating YOLO models.\nThis code was injected into the PyPI release artifacts and was not present\nin the public GitHub repository.","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"A number of releases of ultralytics contained malicious crypto miner software.","id":"PYSEC-2024-154","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2024"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["8.3.47"],"introduced":["8.3.41"],"last_affected":[],"package":"ultralytics","purl":"pkg:pypi/ultralytics","source":"PYSEC-2024-154"}],"products":null,"published":"2024-12-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary code via malicious cryptocurrency miner software injected into compromised ultralytics package releases.","url":"https://insights.sbomify.com/PYSEC-2024-154/"}