# RUSTSEC-2024-0448: `parse_arguments` reads a caller-supplied pointer as a slice

> A Rust library function unsafely converts a caller-supplied pointer to a slice, allowing null dereference or out-of-bounds reads that can cause crashes or memory corruption.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2024

## What is RUSTSEC-2024-0448?

RUSTSEC-2024-0448 is a memory corruption vulnerability in rutie, published on 25 Nov 2024. 

### Official description

`parse_arguments` is safe. It takes `arguments: *const AnyObject` and `argc`, and calls `slice::from_raw_parts(arguments, argc as usize)`.

It does not check that `arguments` is non-null and aligned, or that `argc` elements are initialized. Safe Rust can pass a null pointer or a length past the allocation. The maintainer confirmed this on 2026-10-03, including a debug abort on Rust 1.78+ when Ruby calls an arity -1 method (`to_s` via `format`, `puts`, or `Array#join`) with a NULL `argv` and `argc` of 0.

## Which versions are affected by RUSTSEC-2024-0448?

1 open source package ship an affected version, including rutie.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rutie` | crates.io | From 0.0.0-0 | 0.10.3, 0.11.3, 0.12.1, 0.13.1, 0.14.1 |

## How do I fix RUSTSEC-2024-0448?

Upgrade rutie to a fixed version for your release line: 0.10.3, 0.11.3, 0.12.1 or 0.13.1.

## Is RUSTSEC-2024-0448 being exploited?

There is no known exploitation of RUSTSEC-2024-0448 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for RUSTSEC-2024-0448 and fix it if it is affected.

What it is: RUSTSEC-2024-0448 is a memory corruption vulnerability in rutie, published on 25 Nov 2024. 
Exploitation: There is no known exploitation of RUSTSEC-2024-0448 in the wild and no public exploit code.

Affected packages and fixed versions:
- rutie (crates.io): affected from 0.0.0-0; fixed in 0.10.3, 0.11.3, 0.12.1, 0.13.1, 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/RUSTSEC-2024-0448/ (Markdown: https://insights.sbomify.com/RUSTSEC-2024-0448/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/RUSTSEC-2024-0448

---
From sbomify Insights: https://insights.sbomify.com/RUSTSEC-2024-0448/
Summaries are generated and may contain mistakes; the official description above is the record.
