{"answers":{"affected":"1 open source package ship an affected version, including libcrux-ml-dsa.","exploited":"There is no known exploitation of RUSTSEC-2026-0126 in the wild and no public exploit code.","fix":"Upgrade libcrux-ml-dsa to 0.0.9 or later.","what":"RUSTSEC-2026-0126 is a denial of service vulnerability in libcrux-ml-dsa, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for RUSTSEC-2026-0126 and fix it if it is affected.\n\nWhat it is: RUSTSEC-2026-0126 is a denial of service vulnerability in libcrux-ml-dsa, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of RUSTSEC-2026-0126 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libcrux-ml-dsa (crates.io): affected from 0.0.0-0; fixed in 0.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/RUSTSEC-2026-0126/ (Markdown: https://insights.sbomify.com/RUSTSEC-2026-0126/index.md)","id":"RUSTSEC-2026-0126","markdown":"https://insights.sbomify.com/RUSTSEC-2026-0126/index.md","name":"RUSTSEC-2026-0126","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust ML-DSA library","requires_auth":"none","summary":"An incomplete reduction in the AVX2 implementation of ML-DSA can cause panics, potentially leading to denial of service in applications using the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The AVX2 implementation of ML-DSA did not fully reduce intermediate\ninputs to the inverse NTT, which leads to a testable difference in\npanic behaviour of internal functions compared to the portable\nimplementation.\n\n## Impact\nWe are not aware of inputs to the public key generation, signing or\nverification APIs that trigger a panic in the AVX2 implementation\nbecause the intermediate values were not fully reduced.\n\n## Mitigation\nFrom version `0.0.9` intermediate values on AVX2 platforms are fully\nreduced in alignment with the portable implementation.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"AVX2 Implementation Did Not Fully Reduce Intermediate Values","id":"RUSTSEC-2026-0126","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.0.9"],"introduced":["0.0.0-0"],"last_affected":[],"package":"libcrux-ml-dsa","purl":"pkg:cargo/libcrux-ml-dsa","source":"RUSTSEC-2026-0126"}],"products":null,"published":"2026-04-27","related":[],"sources":[{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An incomplete reduction in the AVX2 implementation of ML-DSA can cause panics, potentially leading to denial of service in applications using the library.","url":"https://insights.sbomify.com/RUSTSEC-2026-0126/"}