{"answers":{"affected":"1 open source package ship an affected version, including nostr.","exploited":"There is no known exploitation of RUSTSEC-2026-0227 in the wild and no public exploit code.","fix":"Upgrade nostr to 0.44.7 or later.","what":"RUSTSEC-2026-0227 is a denial of service vulnerability in nostr, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for RUSTSEC-2026-0227 and fix it if it is affected.\n\nWhat it is: RUSTSEC-2026-0227 is a denial of service vulnerability in nostr, published on 1 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of RUSTSEC-2026-0227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nostr (crates.io): affected from 0.0.0-0; fixed in 0.44.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/RUSTSEC-2026-0227/ (Markdown: https://insights.sbomify.com/RUSTSEC-2026-0227/index.md)","id":"RUSTSEC-2026-0227","markdown":"https://insights.sbomify.com/RUSTSEC-2026-0227/index.md","name":"RUSTSEC-2026-0227","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust NIP-44 library","requires_auth":"none","summary":"Attackers can cause denial of service by sending oversized payloads to applications using this Rust library for NIP-44 decryption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"The NIP-44 decryption entry point Base64-decoded the complete attacker-controlled\npayload before determining its version or enforcing any size limit. For v2 payloads,\nthe decoded buffer was then authenticated with HMAC even when it was much larger than\nthe maximum payload supported by the crate's current v2 codec.\n\nA malicious relay or event author could deliver an oversized value to an application\nthat decrypts NIP-44 content. The value caused memory allocation and Base64 and HMAC\nwork proportional to its size before authentication failed; knowledge of the\nconversation key was not required to consume those initial resources. Repeated\npayloads could exhaust memory or CPU and make the receiving application unavailable.\nThe issue does not disclose plaintext or key material and does not bypass message\nauthentication.\n\nDecryption now reads only the encoded version prefix first, derives the bound from\nthe largest payload the current v2 encoder can emit, and rejects oversized encoded\nand decoded payloads before full allocation or HMAC processing. The limit remains in\nthe v2 implementation so a future codec with a different length format can define its\nown bound.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"NIP-44 v2 decryption permits resource exhaustion","id":"RUSTSEC-2026-0227","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.44.7"],"introduced":["0.0.0-0"],"last_affected":[],"package":"nostr","purl":"pkg:cargo/nostr","source":"RUSTSEC-2026-0227"}],"products":null,"published":"2026-08-01","related":[],"sources":[{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service by sending oversized payloads to applications using this Rust library for NIP-44 decryption.","url":"https://insights.sbomify.com/RUSTSEC-2026-0227/"}