# RUSTSEC-2026-0272: Panic-safety unsoundness in `Stack::pop`, `Fifo::pop_front` and `Value::replace_stable` (use-after-free / double-free)

> A double-free vulnerability in Rust container operations allows attackers to corrupt memory and potentially execute code if element destructors panic.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026

## What is RUSTSEC-2026-0272?

RUSTSEC-2026-0272 is an use after free vulnerability in stack_dst, published on 27 Aug 2026. 

### Official description

Three removal and replacement paths destroy an initialized value before
committing the metadata change that removes it. Destruction runs `T::drop()`,
which is user code and may panic. If it does, the commit is skipped and the
container still claims ownership of the already-destroyed value, so its own
destructor drops that value a second time.

`Stack::pop` drops the top value before reducing `next_ofs`. `Stack`'s
destructor pops in a loop, so an unchanged `next_ofs` re-drops the same value.

`Fifo::pop_front` (via `pop_front_inner`) drops the front value before advancing
`read_pos`. An unchanged `read_pos` still points at the destroyed value.

`Value::replace_stable` drops the existing value before writing the replacement.
If the destructor panics the replacement is never written, but the backing
storage still holds the old value's metadata.

This is separate from RUSTSEC-2021-0033, which covered a clone panic on
insertion in `push_cloned` and was fixed in 0.6.1.

## Impact

A heap-owning value is freed twice, corrupting the allocator. Reachable from
safe Rust with any element type whose `Drop` can panic — no `unsafe` on the
caller's side.

* CWE-415 (Double Free)
* CWE-416 (Use-After-Free)

Confirmed under AddressSanitizer, which reports `attempting double-free` on all
three paths.

## Fix

Fixed in 0.8.2.

## Which versions are affected by RUSTSEC-2026-0272?

1 open source package ship an affected version, including stack_dst.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stack_dst` | crates.io | From 0.0.0-0 | 0.8.2 |

## How do I fix RUSTSEC-2026-0272?

Upgrade stack_dst to 0.8.2 or later.

## Is RUSTSEC-2026-0272 being exploited?

There is no known exploitation of RUSTSEC-2026-0272 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for RUSTSEC-2026-0272 and fix it if it is affected.

What it is: RUSTSEC-2026-0272 is an use after free vulnerability in stack_dst, published on 27 Aug 2026. 
Exploitation: There is no known exploitation of RUSTSEC-2026-0272 in the wild and no public exploit code.

Affected packages and fixed versions:
- stack_dst (crates.io): affected from 0.0.0-0; fixed in 0.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/RUSTSEC-2026-0272/ (Markdown: https://insights.sbomify.com/RUSTSEC-2026-0272/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/RUSTSEC-2026-0272

---
From sbomify Insights: https://insights.sbomify.com/RUSTSEC-2026-0272/
Summaries are generated and may contain mistakes; the official description above is the record.
