# RUSTSEC-2026-0392: Uninitialized memory exposed by `write::Decoder` on a corrupt legacy frame


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Oct 2026

## What is RUSTSEC-2026-0392?

RUSTSEC-2026-0392 is a vulnerability in zstd, published on 16 Oct 2026. 

### Official description

From 0.4.22 to 0.7.x, the writer behind `zstd::stream::write::Decoder` set
its output buffer's length to its full capacity before each decompression
call, then to the position the call reported, and only checked for an error
afterwards. When decompression fails inside a legacy (zstd v0.4 to v0.7)
frame, the bundled zstd library reports the output as fully written although
nothing was written, so stale heap memory, up to the buffer size (32 KiB by
default), was passed to the wrapped writer.

Legacy support is enabled by default, and a few bytes of corrupt legacy
frame are enough. Whether this reaches an attacker depends on where the
application sends the decompressed output.

From 0.8.0, the writer uses zstd-safe's buffers, and the same flaw there is
covered by the zstd-safe advisory for it, fixed in zstd-safe 8.2.0.

## Which versions are affected by RUSTSEC-2026-0392?

1 open source package ship an affected version, including zstd.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zstd` | crates.io | From 0.4.22 | 0.8.0 |

## How do I fix RUSTSEC-2026-0392?

Upgrade zstd to 0.8.0 or later.

## Is RUSTSEC-2026-0392 being exploited?

There is no known exploitation of RUSTSEC-2026-0392 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for RUSTSEC-2026-0392 and fix it if it is affected.

What it is: RUSTSEC-2026-0392 is a vulnerability in zstd, published on 16 Oct 2026. 
Exploitation: There is no known exploitation of RUSTSEC-2026-0392 in the wild and no public exploit code.

Affected packages and fixed versions:
- zstd (crates.io): affected from 0.4.22; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/RUSTSEC-2026-0392/ (Markdown: https://insights.sbomify.com/RUSTSEC-2026-0392/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/RUSTSEC-2026-0392

---
From sbomify Insights: https://insights.sbomify.com/RUSTSEC-2026-0392/
Summaries are generated and may contain mistakes; the official description above is the record.
