{"answers":{"affected":"","exploited":"There is no known exploitation of SUSE-SU-2018:3572-1 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"SUSE-SU-2018:3572-1 is a vulnerability in apache2-mod_nss, published on 30 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for SUSE-SU-2018:3572-1 and fix it if it is affected.\n\nWhat it is: SUSE-SU-2018:3572-1 is a vulnerability in apache2-mod_nss, published on 30 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of SUSE-SU-2018:3572-1 in the wild and no public exploit code.\n\nAffected product: apache2-mod_nss. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/SUSE-SU-2018-3572-1/ (Markdown: https://insights.sbomify.com/SUSE-SU-2018-3572-1/index.md)","id":"SUSE-SU-2018:3572-1","markdown":"https://insights.sbomify.com/SUSE-SU-2018-3572-1/index.md","name":"SUSE-SU-2018:3572-1","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NSS module","requires_auth":"none","summary":"Update required for Apache NSS module to support SQLite certificate database and TLS changes, tagged as security for distribution purposes.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This update for apache2-mod_nss fixes the following issues:\n\nDue to the update of mozilla-nss apache2-mod_nss needs to be updated to change\nto the SQLite certificate database, which is now the default (bsc#1108771).\nBecause of that this update is tagged as security, to reach customers that only\ninstall secuirty updates.\n\nOther changes contained:\n\n- Require minimal NSS version of 3.25 because of SSLv2 changes (bsc#993642)\n- Add support for SHA384 TLS ciphers (bsc#863035)\n- Remove deprecated NSSSessionCacheTimeout option from mod_nss.conf.in (bsc#998176)\n- Change ownership of the gencert generated NSS database so apache can read it (bsc#998180)\n- Use correct configuration path in mod_nss.conf.in (bsc#996282)\n- Generate dummy certificates if there aren't any in mod_nss.d (bsc#998183)","ecosystems":["SUSE:Linux Enterprise Server 12-LTSS"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Security update for apache2-mod_nss","id":"SUSE-SU-2018:3572-1","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2018"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12-LTSS","fixed":["1.0.14-10.17.2"],"introduced":["0"],"last_affected":[],"package":"apache2-mod_nss","purl":"pkg:rpm/suse/apache2-mod_nss\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012-LTSS","source":"SUSE-SU-2018:3572-1"}],"products":null,"published":"2018-10-30","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Update required for Apache NSS module to support SQLite certificate database and TLS changes, tagged as security for distribution purposes.","url":"https://insights.sbomify.com/SUSE-SU-2018-3572-1/"}