SUSE-SU-2024:0076-1 Security update for hawk2
Not scored
Published
Check this codebase for SUSE-SU-2024:0076-1 and fix it if it is affected.
What it is: SUSE-SU-2024:0076-1 is a vulnerability in hawk2, published on 10 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of SUSE-SU-2024:0076-1 in the wild and no public exploit code.
Affected product: hawk2. No package-level version data is available, so check the vendor advisory linked from the reference page.
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/SUSE-SU-2024-0076-1/ (Markdown: https://insights.sbomify.com/SUSE-SU-2024-0076-1/index.md)
An attacker can perform cross-site request forgery attacks against the Hawk2 web interface, potentially bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is SUSE-SU-2024:0076-1?
SUSE-SU-2024:0076-1 is a vulnerability in hawk2, published on 10 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
This update for hawk2 fixes the following issues:
- Fixed HttpOnly secure flag by default (bsc#1216508).
- Fixed CSRF in errors_controller.rb protection (bsc#1216571).
Update to version 2.6.4+git.1702030539.5fb7d91b:
- Fix mime type issue in MS windows (bsc#1215438)
- Parametrize CORS Access-Control-Allow-Origin header (bsc#1213454)
- Tests: upgrate tests for ruby3.2 (tumbleweed) (bsc#1215976)
- Upgrade for ruby3.2 (tumbleweed) (bsc#1215976)
- Forbid special symbols in the category (bsc#1206217)
- Fix the sass-rails version on ~5.0 (bsc#1208533)
- Don't delete the private key if the public key is missing (bsc#1207930)
- make-sle155-compatible.patch . No bsc, it's for backwards compatibility.
Which versions are affected by SUSE-SU-2024:0076-1?
Linux distribution packages (7)
hawk2 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 SUSE:Linux Enterprise High Availability Extension 15 SP5 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 openSUSE:Leap 15.4 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
hawk2 openSUSE:Leap 15.5 | All versions | 2.6.4+git.1702030539.5fb7d91b-150000.3.39.1 |
How do I fix SUSE-SU-2024:0076-1?
Upgrade to a fixed version.
Is SUSE-SU-2024:0076-1 being exploited?
There is no known exploitation of SUSE-SU-2024:0076-1 in the wild and no public exploit code.