{"answers":{"affected":"","exploited":"There is no known exploitation of SUSE-SU-2024:0076-1 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"SUSE-SU-2024:0076-1 is a vulnerability in hawk2, published on 10 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for SUSE-SU-2024:0076-1 and fix it if it is affected.\n\nWhat it is: SUSE-SU-2024:0076-1 is a vulnerability in hawk2, published on 10 Jan 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of SUSE-SU-2024:0076-1 in the wild and no public exploit code.\n\nAffected product: hawk2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/SUSE-SU-2024-0076-1/ (Markdown: https://insights.sbomify.com/SUSE-SU-2024-0076-1/index.md)","id":"SUSE-SU-2024:0076-1","markdown":"https://insights.sbomify.com/SUSE-SU-2024-0076-1/index.md","name":"SUSE-SU-2024:0076-1","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SUSE Hawk2 web interface","requires_auth":"low_privilege","summary":"An attacker can perform cross-site request forgery attacks against the Hawk2 web interface, potentially bypassing security controls.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This update for hawk2 fixes the following issues:\n\n- Fixed HttpOnly secure flag by default (bsc#1216508).\n- Fixed CSRF in errors_controller.rb protection (bsc#1216571).\n\nUpdate to version 2.6.4+git.1702030539.5fb7d91b:\n\n- Fix mime type issue in MS windows (bsc#1215438)\n- Parametrize CORS Access-Control-Allow-Origin header (bsc#1213454)\n- Tests: upgrate tests for ruby3.2 (tumbleweed) (bsc#1215976)\n- Upgrade for ruby3.2 (tumbleweed) (bsc#1215976)\n- Forbid special symbols in the category (bsc#1206217)\n- Fix the sass-rails version on ~5.0 (bsc#1208533)\n- Don't delete the private key if the public key is missing (bsc#1207930)\n- make-sle155-compatible.patch . No bsc, it's for backwards compatibility.","ecosystems":["SUSE:Linux Enterprise High Availability Extension 15 SP1","SUSE:Linux Enterprise High Availability Extension 15 SP2","SUSE:Linux Enterprise High Availability Extension 15 SP3","SUSE:Linux Enterprise High Availability Extension 15 SP4","SUSE:Linux Enterprise High Availability Extension 15 SP5","openSUSE:Leap 15.4","openSUSE:Leap 15.5"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Security update for hawk2","id":"SUSE-SU-2024:0076-1","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":7,"n_references":null,"packages":[{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP1","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/suse/hawk2\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP1","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP2","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/suse/hawk2\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP2","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP3","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/suse/hawk2\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP3","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP4","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/suse/hawk2\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP4","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP5","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/suse/hawk2\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP5","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/opensuse/hawk2\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2024:0076-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["2.6.4+git.1702030539.5fb7d91b-150000.3.39.1"],"introduced":["0"],"last_affected":[],"package":"hawk2","purl":"pkg:rpm/opensuse/hawk2\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:0076-1"}],"products":null,"published":"2024-01-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can perform cross-site request forgery attacks against the Hawk2 web interface, potentially bypassing security controls.","url":"https://insights.sbomify.com/SUSE-SU-2024-0076-1/"}