SUSE-SU-2024:4416-1 Security update for vhostmd
Not scored
Published
Check this codebase for SUSE-SU-2024:4416-1 and fix it if it is affected.
What it is: SUSE-SU-2024:4416-1 is a vulnerability in vhostmd, published on 24 Dec 2024.
Exploitation: There is no known exploitation of SUSE-SU-2024:4416-1 in the wild and no public exploit code.
Affected product: vhostmd. No package-level version data is available, so check the vendor advisory linked from the reference page.
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/SUSE-SU-2024-4416-1/ (Markdown: https://insights.sbomify.com/SUSE-SU-2024-4416-1/index.md)
Update vhostmd to fix buffer accounting, command execution issues, and configuration handling in virtualization metrics collection.
- Exploited in the wild
- Not known
- Login needed
- Not stated
- Attackable
- Not stated
- Victim action needed
- Not needed
- Fix
- Available
What is SUSE-SU-2024:4416-1?
SUSE-SU-2024:4416-1 is a vulnerability in vhostmd, published on 24 Dec 2024.
Official description
This update for vhostmd fixes the following issues:
Updated to version 1.2
- Fix actions using the 'free' command
- Fix buffer accounting when generating metric XML
- Change actions to retrieve vendor and product info
- Add a 'unit' attribute to the metrics element
- vif-stats.py: convert to Python3
- conf: Update the 'VirtualizationVendor' action to strip any URLs that may follow the vendor name (bsc#1230961)
- Fix virtio transport to work with libvirt >= 9.7.0
- Added hardening to systemd service (bsc#1181400)
- spec: Don't replace user-modified dtd in /etc/vhostmd/ (bsc#1154838)
- Relax virtio requirement in config file (bsc#1152803)
Updated to version 1.1 (bsc#1129772)
- Merge libserialclient with libmetrics
- Misc bug fixes and improvements
Which versions are affected by SUSE-SU-2024:4416-1?
Linux distribution packages (2)
vhostmd SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 1.2-150600.17.3.1 |
vhostmd openSUSE:Leap 15.6 | All versions | 1.2-150600.17.3.1 |
How do I fix SUSE-SU-2024:4416-1?
Upgrade to a fixed version.
Is SUSE-SU-2024:4416-1 being exploited?
There is no known exploitation of SUSE-SU-2024:4416-1 in the wild and no public exploit code.