{"answers":{"affected":"","exploited":"There is no known exploitation of SUSE-SU-2025:20255-1 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"SUSE-SU-2025:20255-1 is a vulnerability in python-requests, published on 28 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for SUSE-SU-2025:20255-1 and fix it if it is affected.\n\nWhat it is: SUSE-SU-2025:20255-1 is a vulnerability in python-requests, published on 28 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of SUSE-SU-2025:20255-1 in the wild and no public exploit code.\n\nAffected product: python-requests. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/SUSE-SU-2025-20255-1/ (Markdown: https://insights.sbomify.com/SUSE-SU-2025-20255-1/index.md)","id":"SUSE-SU-2025:20255-1","markdown":"https://insights.sbomify.com/SUSE-SU-2025-20255-1/index.md","name":"SUSE-SU-2025:20255-1","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HTTP library","requires_auth":"none","summary":"An attacker can bypass SSL certificate verification in python-requests if verify=False is set, allowing man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This update for python-requests fixes the following issues:\n\n- Add patch to inject the default CA bundles if they are not specified.\n    (bsc#1226321, bsc#1231500)\n\n- Remove Requires on python-py. \n\n- update to 2.32.3:\n  * Fixed bug breaking the ability to specify custom SSLContexts\n    in sub-classes of HTTPAdapter.\n  * Fixed issue where Requests started failing to run on Python\n    versions compiled without the `ssl` module.\n\n  * To provide a more stable migration for custom HTTPAdapters impacted by the CVE changes in 2.32.0,\n    we've renamed _get_connection to a new public API, get_connection_with_tls_context. Existing\n    custom HTTPAdapters will need to migrate their code to use this new API. get_connection is\n  * Fixed an issue where setting verify=False on the first request from a Session\n    will cause subsequent requests to the same origin to also ignore cert verification,\n  * verify=True now reuses a global SSLContext which should improve request time\n  * Requests now supports optional use of character detection (chardet or charset_normalizer)\n    when repackaged or vendored. This enables pip and other projects to minimize their","ecosystems":["SUSE:Linux Micro 6.1"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Security update for python-requests","id":"SUSE-SU-2025:20255-1","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"SUSE:Linux Micro 6.1","fixed":["2.32.3-slfo.1.1_2.1"],"introduced":["0"],"last_affected":[],"package":"python-requests","purl":"pkg:rpm/suse/python-requests\u0026distro=SUSE%20Linux%20Micro%206.1","source":"SUSE-SU-2025:20255-1"}],"products":null,"published":"2025-03-28","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can bypass SSL certificate verification in python-requests if verify=False is set, allowing man-in-the-middle attacks.","url":"https://insights.sbomify.com/SUSE-SU-2025-20255-1/"}