{"answers":{"affected":"","exploited":"There is no known exploitation of openSUSE-SU-2017:3448-1 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"openSUSE-SU-2017:3448-1 is a vulnerability in phpMyAdmin, published on 29 Dec 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for openSUSE-SU-2017:3448-1 and fix it if it is affected.\n\nWhat it is: openSUSE-SU-2017:3448-1 is a vulnerability in phpMyAdmin, published on 29 Dec 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of openSUSE-SU-2017:3448-1 in the wild and no public exploit code.\n\nAffected product: phpMyAdmin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/openSUSE-SU-2017-3448-1/ (Markdown: https://insights.sbomify.com/openSUSE-SU-2017-3448-1/index.md)","id":"openSUSE-SU-2017:3448-1","markdown":"https://insights.sbomify.com/openSUSE-SU-2017-3448-1/index.md","name":"openSUSE-SU-2017:3448-1","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"low_privilege","summary":"An attacker can trick a logged-in user into clicking a crafted URL to perform harmful database operations in phpMyAdmin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This update for phpMyAdmin to version 4.7.7 fixes a security issue and bugs.\n    \nThe following vulnerability was fixed:\n    \n- By deceiving a user to click on a crafted URL, it was possible to perform harmful database\n  operations (bsc#1074066, PMASA-2017-09)\n\nThis update also contains all upstream improvements and bugfixes in version 4.7.7:\n\n- various display and UI fixes\n- PHP error fixes\n- Improved deteciton of MySQL server needing SSL connections\n- Support JSON datatype on MariaDB 10.2.7 and newer\n- Fix constructing ALTER query with AFTER\n- Fix changing password on MariaDB cluster","ecosystems":["SUSE:Package Hub 12"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Security update for phpMyAdmin","id":"openSUSE-SU-2017:3448-1","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":1,"n_references":null,"packages":[{"ecosystem":"SUSE:Package Hub 12","fixed":["4.7.7-14.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2017:3448-1"}],"products":null,"published":"2017-12-29","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can trick a logged-in user into clicking a crafted URL to perform harmful database operations in phpMyAdmin.","url":"https://insights.sbomify.com/openSUSE-SU-2017-3448-1/"}