openSUSE-SU-2023:0162-1 Security update for xonotic
Malicious server admins can crash clients or execute arbitrary code via a bug in older Xonotic versions, requiring users to upgrade.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is openSUSE-SU-2023:0162-1?
openSUSE-SU-2023:0162-1 is a memory corruption vulnerability in xonotic, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
This update for xonotic fixes the following issues:
Update to version 0.8.6
SECURITY ALERT: A bug was discovered in versions older than 0.8.6 that is believed to be exploitable by malicious server admins to crash clients or, if they defeat mitigations, execute arbitrary code. (boo#1212632)
update to 0.8.5:
Which versions are affected by openSUSE-SU-2023:0162-1?
Linux distribution packages (4)
xonotic SUSE:Package Hub 15 SP4 | All versions | 0.8.6-bp155.2.3.1 |
xonotic SUSE:Package Hub 15 SP5 | All versions | 0.8.6-bp155.2.3.1 |
xonotic openSUSE:Leap 15.4 | All versions | 0.8.6-bp155.2.3.1 |
xonotic openSUSE:Leap 15.5 | All versions | 0.8.6-bp155.2.3.1 |
How do I fix openSUSE-SU-2023:0162-1?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is openSUSE-SU-2023:0162-1 being exploited?
There is no known exploitation of openSUSE-SU-2023:0162-1 in the wild and no public exploit code.