# openSUSE-SU-2023:0162-1: Security update for xonotic

> Malicious server admins can crash clients or execute arbitrary code via a bug in older Xonotic versions, requiring users to upgrade.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2023

## What is openSUSE-SU-2023:0162-1?

openSUSE-SU-2023:0162-1 is a memory corruption vulnerability in xonotic, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This update for xonotic fixes the following issues:

Update to version 0.8.6

SECURITY ALERT: A bug was discovered in versions older than 0.8.6
that is believed to be exploitable by malicious server admins to
crash clients or, if they defeat mitigations, execute arbitrary code.
(boo#1212632)

update to 0.8.5:

  * https://xonotic.org/posts/2022/xonotic-0-8-5-release/

## Which versions are affected by openSUSE-SU-2023:0162-1?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xonotic` | SUSE:Package Hub 15 SP4 | All versions | 0.8.6-bp155.2.3.1 |
| `xonotic` | SUSE:Package Hub 15 SP5 | All versions | 0.8.6-bp155.2.3.1 |
| `xonotic` | openSUSE:Leap 15.4 | All versions | 0.8.6-bp155.2.3.1 |
| `xonotic` | openSUSE:Leap 15.5 | All versions | 0.8.6-bp155.2.3.1 |

## How do I fix openSUSE-SU-2023:0162-1?

Upgrade to a fixed version.

## Is openSUSE-SU-2023:0162-1 being exploited?

There is no known exploitation of openSUSE-SU-2023:0162-1 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for openSUSE-SU-2023:0162-1 and fix it if it is affected.

What it is: openSUSE-SU-2023:0162-1 is a memory corruption vulnerability in xonotic, published on 29 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of openSUSE-SU-2023:0162-1 in the wild and no public exploit code.

Affected product: xonotic. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/openSUSE-SU-2023-0162-1/ (Markdown: https://insights.sbomify.com/openSUSE-SU-2023-0162-1/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/openSUSE-SU-2023:0162-1

---
From sbomify Insights: https://insights.sbomify.com/openSUSE-SU-2023-0162-1/
Summaries are generated and may contain mistakes; the official description above is the record.
