{"answers":{"affected":"","exploited":"There is no known exploitation of openSUSE-SU-2024:0026-1 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"openSUSE-SU-2024:0026-1 is a vulnerability in seamonkey, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for openSUSE-SU-2024:0026-1 and fix it if it is affected.\n\nWhat it is: openSUSE-SU-2024:0026-1 is a vulnerability in seamonkey, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of openSUSE-SU-2024:0026-1 in the wild and no public exploit code.\n\nAffected product: seamonkey. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/openSUSE-SU-2024-0026-1/ (Markdown: https://insights.sbomify.com/openSUSE-SU-2024-0026-1/index.md)","id":"openSUSE-SU-2024:0026-1","markdown":"https://insights.sbomify.com/openSUSE-SU-2024-0026-1/index.md","name":"openSUSE-SU-2024:0026-1","record":{"aliases":[],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"SeaMonkey browser","requires_auth":"none","summary":"An attacker can execute arbitrary code or escalate privileges by exploiting multiple vulnerabilities in the SeaMonkey browser, requiring user interaction.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This update for seamonkey fixes the following issues:\n\nUpdate to 2.53.18.1:\n\n* Update the NSS library to the latest esr 115 version for the final\n  2.53.18.1 release.\n* SeaMonkey 2.53.18.1 uses the same backend as Firefox and contains\n  the relevant Firefox 60.8 security fixes.\n* SeaMonkey 2.53.18.1 shares most parts of the mail and news code\n  with Thunderbird. Please read the Thunderbird 60.8.0 release notes\n  for specific security fixes in this release.\n* Additional important security fixes up to Current Firefox 115.7\n  and Thunderbird 115.7 ESR plus many enhancements have been\n  backported. We will continue to enhance SeaMonkey security in\n  subsequent 2.53.x beta and release versions as fast as we are able to.","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Security update for seamonkey","id":"openSUSE-SU-2024:0026-1","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["2.53.18.1-bp155.2.15.1"],"introduced":["0"],"last_affected":[],"package":"seamonkey","purl":"pkg:rpm/suse/seamonkey\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0026-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["2.53.18.1-bp155.2.15.1"],"introduced":["0"],"last_affected":[],"package":"seamonkey","purl":"pkg:rpm/opensuse/seamonkey\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0026-1"}],"products":null,"published":"2024-01-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can execute arbitrary code or escalate privileges by exploiting multiple vulnerabilities in the SeaMonkey browser, requiring user interaction.","url":"https://insights.sbomify.com/openSUSE-SU-2024-0026-1/"}